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File menu
When you start WDM, you have four menus to work with: File, View, Preferences, and Help.  
The File menu contains the commands shown on the picture below:

Figure 1 File menu

The program lists the names of the last WDM_Phasar files you have worked with.

When you create a new project or open an existing one, WDM_Phasar provides nine menus 
that contain all commands you'll need to do your work effectively.  Most commands in the File 
menu are similar to those commonly used in Windows applications.

The expanded File menu is shown in Figure 2.
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WDM_PHASAR  FILE MENU
Figure 2 File menu - expanded

New

Opens a new project.

Note: After choosing New from the File menu, you can define a default waveguide using 
the Effective Index Calculator, or you can go directly to the Initial Data dialog box if you click 
the Close button in the Effective Index Calculator dialog box.

Open

Opens an existing project.

Close

Closes the active project.

Note: The program prompts you to save changes before closing the project.

Save

Saves the active project under the current name in the default location.

Save As

Saves the current project with a different name and in a location of your choice.

Export

Exports to BPM 2D and to mask format.

Note: The Export command is specific to the WDM environment.  It allows you to export 
files containing Input Coupler and/or Output Coupler of the WDM Device to BPM 2D.  You 
can also export the WDM Device to GDS II or DXF mask formats.

Print Preview
2



WDM_PHASAR  FILE MENU
Displays a print preview of the active WDM Device.

Print Setup

Allows you to define the printer, set the page size and orientation, and choose other printing 
options.

List of files

Lists the names of the most recent WDM_Phasar files you accessed.

Exit

Allows you to exit the program.

Note: The program prompts you to save changes to the current project.
3



WDM_PHASAR  FILE MENU
New
The New command opens the Effective Index Calculator dialog box and gives you access to 
the Initial Data dialog box.

Effective Index Calculator Dialog Boxes

The Effective Index Calculator dialog boxes allow you to layout a 2D rectangular waveguide 
and calculate the 1D effective index distribution from it.  In the Layout Structure dialog box 
shown in Figure 3, you can add, delete, and edit layers.  You can also define calculation 
parameters and display fields.
4



WDM_PHASAR  FILE MENU
Figure 3 Layer Structure dialog

The different layers are separated (there are four layers in the picture above).  The cladding is 
the top layer, and the substrate is the bottom layer.  In between, you see two layers and the 
thickness and the refractive indices for each of those layers.  When you select a layer and click 
the Edit button, you can edit the thickness and the refractive index of layers and waveguides.

When you open a new project, you can click the Close button to use the default values.  You 
can redefine the parameters of each layer at any time by using the Effective Index command in 
the Design menu.  For a detailed discussion about using the options available in the Effective 
Index Calculator dialog boxes, see the "Effective Index" section of this User Guide.  

Initial Data dialog box

When you close the Effective Index Calculator dialog boxes, the Initial Data dialog box appears.  
In this dialog box, you define the initial data for the device design and the simulation.  You can 
change this data at any time during your work.
5



WDM_PHASAR  FILE MENU
Figure 4 Initial Data dialog

In the Default Waveguide section, the value entered in the Start Width box defines the width of 
the waveguide.  The Waveguide Effective Index is a complex number.  The Number Of Points 
Per Micron determines the discretization in a direction that is perpendicular to propagation in 
the Input/Output Coupler.  The Wavelength is the vacuum wavelength of the light signal.

In the Wafer section, you define the parameters of the wafer, a planar substrate on which you 
design devices.  The length of the wafer is along the Z-axis, which is horizontal on the screen. 
The width of the wafer is along the X-axis, which is vertical on the screen. The origin of the 
coordinate axes is in the middle of the mesh and at the beginning of the propagation.  The 
Wafer effective index is a complex number.

If you want to use the default data entered in the Initial Data dialog box, click the OK button.  
The Parameter dialog box appears.  You can click the OK button to use the suggested 
parameters, or you can define the parameters yourself and then click the OK button.

If you want to change the default wafer parameters available in the Initial Data dialog box, follow 
the steps in the procedure below:

Step Action 
1 To enter data in the Initial Data dialog box

2 From the File menu, click New.

3 In the Device Parameter Setup dialog box, click the Close button.

4 In the Default Waveguide section, type a value in the Start Width box.

5 Type values in the Effective Index boxes.

6 In the Wafer section, type a value in the Length (Propagation) box.

7 Type a value In the Width (Mesh) box.

8 Type a value in the Number of Points Per Micron box.

9 Type a value in the Wavelength box.

10 Click the OK button to close the dialog box and to open a new project.
6
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Export
Unlike the rest of the commands available in the File menu, which are commonly used in 
Windows applications, the Export command is specific to the WDM environment.  
WDM_Phasar provides two export options: 1) you can export Input Couplers and/or Output 
Couplers to BPM 2D where the couplers can be further manipulated and simulated, and 2) you 
can export WDM devices to the following mask formats:
• GDS II: saves the current file in Calma GDS Stream file format (*.gds)
• DXF: saves the file document in a AutoCAD DXF file format (*.dxf)

To export to BPM 2D

Step Action 
1 From the File menu, click Export, To BPM 2D.

2 In the Export To BPM 2D dialog box, enable one of the following buttons:

• Input Coupler Only

• Output Coupler Only

• Both Couplers

3 In the Save As box, type a name for the file to be exported to BPM 2D.
7



WDM_PHASAR  FILE MENU
Figure 5 Export to BPM 2D dialog

4 Click the OK button.

To export to mask formats

Step Action 
1 From the File menu, click Export, To Mask Format.

2 In the Export To Mask Format dialog box, enable one of the following buttons:

3 Calma GDS II Stream Format (*.gds)

4 AutoCAD DXF File (*.dxf)

5 In the Conversion Accuracy box, type a value.

6 In the Save As box, type a name for the file to be exported.

Figure 6 Export to Mask Format dialog

7 Click the OK button.
8
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Edit menu
The Edit menu contains commands used in waveguide device editing.

The Edit menu is shown in Figure 7.

Figure 7 Edit menu

Undo

Cancels the last operation performed.  Used repeatedly, the command continues to reverse 
operations until the last saved operation.

Redo

Cancels the last Undo command.  You can use the Redo command immediately after the Undo 
command to reverse the effect of the Undo command.

Delete

Deletes all selected devices.

Select All

Selects all components of the device in the active window.

Properties

Opens the WDM Device Properties dialog box, which allows you to define or change the 
following device properties:
• Input Port
• Input/Output Sections
• Input/Output Couplers
• Input/Output Phased Array Sections
• Phased Array
• Output Port
• Triangular region

The Properties command is enabled in the Edit menu when you have selected an existing 
device which you want to edit.

See the Create Device section (Design menu) of this manual for more information.
9



WDM_PHASAR  VIEW MENU
View menu
The View menu contains commands used for viewing WDM devices.

Figure 8 View menu

Select

Activates the Select tool (the first tool on the View Tools toolbar) when the Zoom In/Out tool is 
enabled.  The Select tool is enabled by default.

Figure 9 Select tool

Note: When you select a WDM device, the Create Design command and the Device 
Wizard commands in the Design menu are disabled.  WDM_Phasar allows the creation of 
only one device per window.

Zoom

Activates the Zoom In/Out tool (the second tool on the View Tools toolbar).
10



WDM_PHASAR  VIEW MENU
Figure 10 Zoom tool

The Zoom In/Out command allows you to increase or decrease the magnification of the current 
view.  To zoom in, click in the area you want to magnify; to zoom out, click the right mouse 
button in the area you want to reduce.

You can also use this command to get a close-up view only of a section of your device.  To do 
so, click in the substrate and drag the mouse down and to the right until you enclose in a window 
the section you want to zoom in.

Restore Zoom

Activates the Restore Zoom tool (the third tool on the View Tools toolbar).

Figure 11 Restore tool

Restore Zoom cancels the last Zoom In/Out command.

Grid

Displays or hides the grid. Figure 12 shows a displayed grid.
11



WDM_PHASAR  VIEW MENU
Figure 12 Displayed grid

Device Info

Opens the Device Info dialog box.

The Device Info dialog box has two tab options:
• Default Waveguide
• Device View.

The Default Waveguide dialog displays the default waveguide width and refractive index 
(see Figure 13).

The Device View page shows an overview of the whole wafer (see Figure 14). When your work 
area is smaller than the wafer, the work area is marked by a rectangle on the Device View 
window. You can drag the work area and press Apply to change its position.  To restore the 
previous work area position, press Restore.

Figure 13 Device Info dialog - Default Waveguide tab
12



WDM_PHASAR  VIEW MENU
Figure 14 Device Info dialog - Device View tab

Toolbars

Toggles the display of the following toolbars:

Figure 15 Toolbars menu

When a toolbar is displayed, a check mark appears next to the menu item.

To view/hide toolbars

Action 
• From the View menu, click Toolbars. 

The Toolbar menu appears.

Undo Redo displays or hides the Undo/Redo toolbar.

Figure 16 Undo/Redo toolbar

View Tools displays or hides the View Tools toolbar.
13



WDM_PHASAR  VIEW MENU
Figure 17 View Tools toolbar

Draw Options displays or hides the Draw Options toolbar.

Figure 18 Draw Options toolbar

WDM Device displays or hides the WDM Device toolbar.

Figure 19 WDM Device toolbar

Auto Geometry displays or hides the Auto Geometry toolbar.

Figure 20 Auto Geometry toolbar
14
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Templates displays or hides the Templates toolbar.

Figure 21 Templates toolbar

Input Interface displays or hides the Input Interface toolbar.

Figure 22 Input Interface toolbar

Output Interface displays or hides the Output Interface toolbar.

Figure 23 Output Interface toolbar

Main Toolbar displays or hides the Main toolbar.

Figure 24 Main Toolbar

Status Bar

Displays or hides the Status Bar.  When the Status Bar is displayed, a check mark appears next 
to the Status Bar command in the View menu.

Set Toolbars Default

Applies the default for the arrangement of the toolbars on the screen.

Refresh Window

Refreshes the screen.

Note: When you start WDM_Phasar, the View menu is different from the View menu which 
is available when you open an existing project or when you create a device (see ).
15



WDM_PHASAR  VIEW MENU
Figure 25 View menu - start

The menu contains only three commands which allow you to display or hide the toolbars, to 
display or hide the Status Bar, and to use the toolbar defaults.
16



WDM_PHASAR  DESIGN MENU
Design menu
The Design menu, shown in Figure 26, contains commands that allow you to create a WDM 
device and to define and change the device parameters.

Figure 26 Design menu

When you design a device, you can use the following commands:

Effective Index

Opens the Effective Index Calculator dialog box that allows you to calculate the effective index 
based on the refractive indices of the layers of the wafer and the waveguides in the wafer.

You can also use the Effective Index Calculator button (the second button from the right on the 
WDM Device toolbar).

Figure 27 WDM Device toolbar

Wafer Data

Opens the Wafer Data dialog box and allows you to edit the wafer parameters.

Create Device

Allows you to create a device.  The command is disabled when the device already exists.

Note: You can also use the Device Wizard button (the second button from the left on the 
WDM Device toolbar - see Figure 28). 
17
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Device Wizard

Allows you to create a device based on your requirements for its performance.

The command is disabled when the device already exists. For more information about 
designing a WDM device using the Device Wizard command, see Lesson 2 of the 
WDM_Phasar Tutorial.

Note: You can also use the Device Wizard button (the second button from the left on the 
WDM Device toolbar - see Figure 28).

Figure 28 WDM Device toolbar - Create Device/Device Wizard

Auto Geometry

Allows you to adjust the geometry of the device by automatically changing the Orientation Angle 
or the Tip Separation so that all Phased Array paths can be displayed keeping a constant length 
increment for the waveguides in the array.

You can enable or disable one of the following two commands:
• Adjust Angle - automatically changes the Orientation Angles of  the Input and Output 

Couplers so that the device can be displayed.
• Adjust Distance - automatically changes the Tip Separation so that the device can be 

displayed.

Note: This command is available only if the device is selected.  The Adjust Distance 
command can be accessed through the WDM Device Properties dialog box.

The Auto Geometry options can also be accessed from the Auto Geometry toolbar (see Figure 
29).

Figure 29 Auto Geometry toolbar

Template

Allows you to select a template for the phased array.  Each template lets you create a device 
which consists of a combination of straight and arc waveguides.  The names of the templates 
describe the elements involved in the creation of the left half of the device.  The other half is a 
mirror image.  There are four templates available.

Note: The Template command is available only if the device is selected.
18



WDM_PHASAR  DESIGN MENU
Figure 30 Template menu

• SAS Auto Radius - draws a phased array whose left half consists of three waveguides: 
straight, arc, and straight.

Note: For more information, see Appendix II, Template #1

Figure 31 SAS Auto Radius

• SA Auto Radius - draws a phased array whose left half consists of two waveguides: 
straight and arc.

Note: For more information, see Appendix II, Template #2.
19
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Figure 32 SA Auto Radius

• AS Auto Radius - draws a phased array whose left half consists of two waveguides: arc 
and straight.

Note: For more information, see Appendix II, Template #3.

Figure 33 AS Auto Radius

• ASAS 90 Deg Auto Radius - draws a phased array whose left half consists of four 
waveguides: Arc, straight, arc, and straight.

Note: For more information, see Appendix II, Template #4.
20
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Figure 34 ASAS 90 Deg Auto Radius

The template options can be also accessed from the WDM Device Properties dialog box or from 
the Templates toolbar (see Figure 35).

Figure 35 Template toolbar

Input Ports

Allows you to enable or disable the input port and to define the orientation of the input ports 
regarding the wafer boundaries.  There are five options available.
21
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Figure 36 Input Ports menu

• Enabled - when enabled, displays the input ports of the device.  When disabled, hides the 
input ports of the device.

• Left - connects the input ports to left side of the wafer.
• Top - connects the input ports to the top of the wafer.
• Right - connects the input ports to the right side of the wafer.
• Bottom - connects the input ports to the bottom side of the wafer.

Note: The Input Ports command is available only if the device is selected.

You can also access the command from the WDM Device Properties dialog box or from the 
Input Interface toolbar (see Figure 37).

Figure 37 Input Interface toolbar
22
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Output Ports

Allows you to enable or disable the output ports and to define the orientation of the output ports.

Figure 38 Output Ports menu

• Enabled - when enabled, displays the output ports of the device; when disabled, hides the 
output ports of the device

• Left - connects the output ports to the left side of the wafer.
• Top - connects the output ports to the top side of the wafer.
• Right - connects the output ports to the right side of the wafer.

Bottom - connects the output ports to the bottom side of the wafer.

Note: The Output Ports command is available only if the device is selected.

You can also access the command from the WDM Device Properties dialog box or from the 
Output Interface toolbar (see Figure 39).

Figure 39 Output Interface toolbar

Recalculate Device

Initiates a recalculation of the geometry of the whole device based on the current set of 
parameters.
23
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Effective Index
The Effective Index command is used to layout the cross-section of a waveguide and enter the 
light wavelength and polarization.  Once these data are entered, the two dimensional index 
distribution of the waveguide will be reduced to an equivalent slab waveguide.  This slab 
waveguide has a one-dimensional cross-section consisting of three layers: the effective index 
of the waveguide in the centre layer (the slab), and the wafer index on either side (the cladding).  
The Effective index command will also find the possible waveguide modes, plot the mode 
profiles, and estimate the modal indices of these modes using the Weighted Index Method.  For 
more information on the Weighted Index Method, see the Technical Background section of the 
WDM_Phasar manual.

Effective Index Dialog Boxes

The Effective Index command opens a series of boxes which define the waveguide and the 
optical modes inside it.  The Device Parameter Setup dialog box is shown in Figure 40.
24
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Figure 40 Device Parameter Setup dialog box

In this box the wavelength and polarization of the light are defined.  The Waveguide Width is 
the width of the rib, if rib waveguides are used.  In the case of buried waveguides, the 
Waveguide Width will mean the width of the waveguide itself. 

After pressing the Edit Layers button the second box of the Effective Index Calculator appears.  
This dialog box lets you add, delete, and edit layers.
25
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Figure 41 Layer Structure dialog box

The different layers are separated (in the picture above, for example, there are four layers).  The 
cladding is the top layer, and the substrate is the bottom layer.  In between, you can create any 
number of layers and define the refractive index, thickness, and waveguide parameters for 
each layer.  A waveguide is displayed in a given layer only if the Waveguide Refractive Index 
is different from the Layer Refractive Index in this layer.

To add layer(s) to the design

Step Action 
1 In the Layer Structure dialog box, click a layer to select it.

2 Click the Add button.
The program will add a new layer on top of the selected one.
26
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To delete a layer from the design

Step Action 
1 In the Layer Structure dialog box, select a layer by clicking it.

2 Click the Delete button.
The layer is deleted.

To edit a layer using the Layer dialog box

Step Action 
1 In the Layer Structure dialog box, click a layer to select it.

2 Click the Edit button to open the Layer dialog box.

3 In the Layer dialog box, type a value for the thickness of the layer in the 
Thickness box.

4 In the Layer Refractive Index section, type values in the box.

5 In the Waveguide Refractive Index section, type values in the box.
27
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Figure 42 Layer dialog box

6 Click the OK button.

Note: To be able to work with a particular layer, you have to select it first.

Note: You can also open the Layer box by double-clicking a layer.

Note: f the refractive index of the waveguide is the same as the refractive index of the layer, 
the waveguide for this layer will not exist, and the layer will be considered to be a substrate 
layer instead.

Tips
• To increase or decrease the size of a layer, click it and drag it up or down until you get the 

desired result.
• To change the refractive index of a layer, you can also click in the Colour Coded Strip box 

and move the cursor up or down.  You'll see that the colour applied to the layer changes as 
well.

• To define the refractive index of the waveguide, you can also click the right mouse button 
and move the cursor up or down until you get the desired result.
28
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To calculate the effective index of the waveguide

Step Action 
1 In the Layer Structure dialog box, click the Calculate button.

Note: Using the weighted index method of calculation, the program will 
reduce the 2D waveguide refractive index distribution to 1D effective index 
distribution, as shown in the picture below.

Figure 43 Mode Calculator dialog box

To display the modal indices of the guided modes

Step Action 
1 In the Mode Calculator dialog box, click the Modes button.

The Modal Indices box will appear with a list of guided modes and their modal 
indices.
29
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Figure 44 Modal Fields dialog box

To view the modal field distribution

Step Action 
1 In the Modal Indices dialog box, click a mode from the list to select it.

2 Click the Display Field button.
The Field Display box will appear. The field distribution of the selected mode 
will be shown superimposed on the effective index distribution.

3 In the Field Display dialog box, click the right mouse button to display a pop-
up menu.

Figure 45 Field Display dialog box
30
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Field Display Options

Zoom In

The Zoom In option zooms into the graph by dragging a rectangle around the graph, and 
displays zoomed in values on both axes.

Zoom Out

Zoom Out returns the graph to default scale (no zoom at all).

Trace Curve

Trace Curve offers the unique option of tracing a particular curve on this View.  When selected, 
a Select Trace Curve dialog box offering a list of all of the curves on the View appears.

Figure 46 Select Traced Curve dialog box

The user selects a curve. The selected curve is being inspected.  Moving the cursor moves the 
crosshair that traces along the selected curve and the window displayed on top of the View will 
show the X and Y values.  This is useful when observing exact values at particular X values, as 
opposed to just viewing the graph.
31
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Figure 47 Field Display dialog box

From the drop-down box, any other curve in this View can be selected and the crosshair will 
continue by tracing that particular curve.  Selecting the Trace Curve feature again will disable 
this feature.

Table of Points

This option will show a dialog box, which can be used to view the data points of the curves in 
the graph.
32
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Figure 48 Data Points Display dialog box

From the drop down menu, any curve in the view can be selected.  The data points of the curve 
will be displayed in the table.  The display format options can be changed by choosing the new 
display format, and/or by changing the number of digits, and then pressing the Update Format 
button. The data points of the currently displayed curve can also be saved into a text file, by 
pressing the Export Text button.  This will open the Save dialog box, which will ask for the 
location to save the file.

Print/Print to File/Copy Bitmap

To get a printout of the graph, right click the mouse and select this option.  The Print to File 
option has a submenu in which you can select an output format of bitmap or enhanced metafile.  
The enhanced metafile is a vector based graphic which can be inserted into Word documents 
as a picture.  The Copy Bitmap option will make a copy of the graph which can be pasted into 
other applications. 

Curve Properties

Another option from this menu is Curve Properties.  Curve Properties offers a list of curves 
where the curve colour, line style, thickness, and the type of graph points that it will draw can 
be modified.  If too many curves are displayed at the same time, curves can also be set to 
invisible (and not show up on the graph) to reduce the clutter.
33
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Figure 49 Curve Properties dialog box

Axis Properties

The next option from the menu is Axis Properties.  All the active axes are offered as choices for 
property modification.
34
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Figure 50 Axis Properties dialog boxo

It supports three number formats: floating, exponent and power.

Other parameters for graphs include the number of digits displayed and orientation with respect 
to the axes.  Modification of the axis captions, orientation, as well as the size of the axis (Scale 
Factor) can be done, as well as the entering of particular mathematical symbols within the 
caption by choosing the Symbols button in the bottom right corner.

On the right-hand side, the Auto Scale option automatically scales the axes to the graph, as 
well as the Logarithmic option for logarithmic display of data. The same options are offered for 
all the axes. 

Grid Properties

Grid View Properties supports editing of horizontal and vertical grids.  In all grid options, the 
user can decide whether the grid is visible, where the grids should be positioned (on major or 
minor tick marks), the colour of the grid, and the line style of the grid.

Graph Properties

The properties of the graph can be edited in the Graph Properties option.

The Title box offers the option of editing the caption (title) of a Graph, as well as the position, 
size, and scale factor.
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Figure 51 Graph Properties dialog box

The Colours option allows for the selection of the colours of the axes and the background.

Labels

Labels in the Graph View can be added by choosing the Label, Add option, and typing it in.  
Once created, the label can be moved around the graph, using the click and drag technique, in 
order to label any part of the graph.  The labels can also be resized by dragging the corners of 
a label
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Figure 52 Field Display dialog box

To open the Initial Data dialog box

Step Action 
1 In the Modal Fields dialog box, click the Close button.

2 In the Mode Calculator dialog box, click the Close Button.
The Initial Data dialog box appears.
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Figure 53 Initial Data dialog box

In the Initial Data dialog box, the values for the waveguide, the waveguide width, the 
wavelength, and the wafer indices are the default values transferred from the Effective Index 
Calculator.

Note: The Initial Data dialog box does not open when you click the Close button in the 
Mode Calculator dialog box if you are already working with an existing project.
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Wafer Data
The Wafer Data command opens the Wafer Data dialog box.

The Wafer Data dialog box allows you to change the length and the width of the wafer.  You 
can also edit the effective index of the wafer.

To define wafer parameters

Step Action 
1 From the Design menu, click Wafer Data.

The Wafer Data Dialog box appears.

Figure 54 Wafer Data dialog box

2 In the Wafer Data dialog box, type a value in the Length (Propagation) box.

3 Type a value in the Width (Mesh) box.

4 Type values in the Real and Imaginary Effective Index boxes.

5 Click the OK button.
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Create Device
There are two ways to create a device: by using the Create Device command or by using the 
Device Wizard (see Figure 55).

Figure 55 Device list

The Create Device command gives you access to the WDM Device Properties dialog box that 
contains all the parameters for the device.

You can use the WDM Device Properties dialog box to edit the WDM Device geometric and 
material parameters.  The dialog box contains seven tabs (when the Symmetrical Couplers 
check box is enabled) that allow you to view and define the parameters of the different 
components of the WDM device.
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Figure 56 WDM Device Properties dialog box

The co-ordinates of the tip of the input coupler and  the separation between the couplers is 
specified in this box.  

This box includes the option to use the Auto Geometry feature.  It contains a radio button for 
selecting either the orientation angle of the couplers, or the distance between the couplers.  If 
the check box is enabled, the program will try to maximise the number of waveguides which can 
be drawn by varying the selected parameter.  The essential feature of the phased array is that 
the difference in path length of adjacent paths should be a certain constant.  If this is impossible 
owing to the constraints of the geometry, the waveguides which cannot conform will not be 
drawn, and will appear as broken waveguides in the device layout.

When the Symmetrical Coupler check box is disabled, the WDM Device Properties dialog box 
displays ten tabs (as shown below).
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Figure 57 WDM Device Properties dialog box tabs

Note: Notice that by default the Symmetrical Couplers check box is enabled, that is, the 
Phased Array is symmetrical, and the Output Star Coupler is a mirror image of the Input 
Star Coupler.

You can also open the WDM Device Properties dialog box by selecting the device and clicking 
Properties from the Edit menu or by double-clicking on the device.

For a detailed description of the device elements, see Appendix I of the WDM_Phasar Atlas.

For more information about using the path templates, see Appendix II (Templates 1, 2, 3, and 
4) of the WDM_Phasar Atlas.

Input tab

When you access the WDM Device Properties dialog box, the Input tab is enabled by default, 
and you see the default data entered on the Input page.  You can create a device by using the 
default settings, or you can design your own device by entering new parameters.

To define the Input Port parameters

Step Action 
1 If you want to connect the input ports to the wafer border, follow steps 2 to 5.
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2 Enable the Connect To Wafer Border check box.

• Enable one of the following buttons:

• TOP

• BOTTOM

• L (Left)

• R (Right)

3 In the Connection Offset box, type a value to define the distance from the 
edge of the wafer to the centre of the first port waveguide.

4 In the Port Separation box, type a value to define the distance between the 
centres of the port waveguides.

Note: If a non-uniform spacing is desired, switch the radio button to 
Individual, and enter the separations in the pop-up box.

5 Optical radiation losses can be reduced at the boundary between bent 
waveguides and straight waveguides by offsetting the straight waveguide 
from the curved one.

Note: If the Optimum Waveguide Offset checkbox is enabled, the program 
will calculate the optimum offset at every input waveguide junction, and make 
the appropriate offset in the waveguide layout.
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Figure 58 Input tab

Note: You can also define the input port parameters by using the buttons on the Input 
Interface toolbar.

For more information about input ports, see Input Ports Section in WDM_Phasar Atlas - 
Appendix I.

Input/Output Section tab

On the Input/Output tab of the WDM Device Properties dialog box, you have access to the 
parameters of the Input Section of the Input Coupler and the Output Section of the Output 
Coupler.

To define the Input Section parameters

Step Action 
1 In the WDM Device Properties dialog box, click the I/O Sect. Tab.

2 In the Radius box, enter a value for the radius of the input surface of the Free 
Propagation Region.

3 In the Number Of Waveguides box, enter a value for the number of 
waveguides.

4 In the Minimum Waveguide Separation box, enter a value for the separation 
from centre to centre.

Note: If a regular spacing of the waveguides is not desired, the space 
between each waveguide can be independently specified.  For individual 
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specification, change the radio button to the individual case, and edit the list 
of spacings by clicking the Edit Separation button.

5 In the Waveguide Length box, enter a value to define the length of the 
waveguide.

6 In the Waveguide Effective Index boxes, enter values for the real and the 
imaginary indices.

Note: If not all waveguides have the same value, the waveguide indices can 
be entered one at a time by clicking the Individual Value radio button and then 
the Edit Effective Indices button.

7 If tapered waveguides are desired at the input and output ends of the 
couplers, click the Tapered Entry checkbox.  Then select the kind of taper 
(linear, parabolic, or exponential), and enter values for the tapered start/end 
width and length.

Note: Parabolic tapers are set to match the slope of the parabola to the slope 
of the waveguide boundaries at the beginning of the taper.  In the case of 
exponential taper, the coefficient in the exponent can be set in the box 
labelled "alpha".

Figure 59 Input/Output Section tab

Note: When the Tapered Entry check box is enabled, the tapers Start Width and End Width 
boxes are initialised with the current value in the Waveguide Width box.

When the Symmetrical Coupler check box is disabled, the WDM Device Properties dialog box 
contains two separate pages: one for Input Section - Input Coupler and one for Output Section 
- Output Coupler.

For more information, see Input Section/Output Section in WDM_Phasar Atlas - Appendix I.
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Input/Output Coupler tab

On the Input/Output Coupler page of the WDM Device Properties dialog box, you access and 
edit the parameters of the Free Propagation Region of the Input and Output Couplers.

To define the Input/Output Coupler parameters

Step Action 
1 In the WDM Device Properties dialog box, click the I/O Coupler tab.

2 In the Coupler Length box, enter a value for the length of the Free 
Propagation Region element.

3 In the Orientation Angle box, enter a value for the angle between the 
horizontal axis and the central line of the Free Propagation Region.

4 In the Angular Width box, enter a value for the angular opening of the Free 
Propagation Region seen from the Tip.

5 In the Effective Index boxes, enter value for the real and the imaginary 
indices.

6 The I/O Section Offset angle moves the input and output arrays away from 
the centre line of the input coupler.  Enter 0.0 for a symmetric device.

7 Enabling the Transition Region checkbox allows the re-definition of the wafer 
index in an annular region just outside the coupler.

Note: The wafer index is used as the cladding of the waveguides in the slab 
waveguide approximation.
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Figure 60 Input/Output Coupler tab

Note: The options available on the I/O Coupler in the Tip Position section are disabled for 
the symmetrical couplers.  You can specify the tip position for the Input Coupler and the tip 
separation between the couplers by using the WDM Device Properties dialog box.

Note: When the Symmetrical Coupler check box is disabled, the WDM Device Properties 
dialog box contains two separate pages: one for Input Coupler and one for Output Coupler.

For more information, see Input Coupler/Output Coupler in WDM_Phasar Atlas - Appendix I.
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Input/Output Phased Array Section tab

On the Input/Output Phased Array tab of the WDM Device Properties dialog box, you have 
access to the parameters of the Phased Array Section of the Input/Output Coupler.

To define the Input/Output Phased Array Section parameters

Step Action 
1 In the WDM Device Properties dialog box, click the I/O PA Sect. tab.

2 In the Radius box, enter a value for the radius of the output surface for the 
Free Propagation Region.

3 In the Number of Waveguides box, enter a value for the number of the 
waveguides.

4 In the Minimum Waveguide Separation box, enter a value for the separation 
from center to center.

5 In the Waveguide Length box, enter a value for the length of the first 
waveguide in the phased array path.

6 In the Waveguide Width box, enter a value for the width of the waveguide.

7 In the Tapered Entry section (when the Tapered Entry check box is enabled), 
enter values for the taper start and end width and length. Then select the kind 
of taper (linear, parabolic, or exponential), and enter values for the tapered 
start/end width and length.  Parabolic tapers are set to match the slope of the 
parabola to the slope of the waveguide boundaries at the beginning of the 
taper.

Note: In the case of exponential taper, the coefficient in the exponent can be 
set in the box labelled "alpha".

8 Enter the value of effective index in the taper region.  If these values are not 
equal, switch to the Individual Index radio button and then Edit Effective 
Indices to set the individual values.
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Figure 61 Input/Output Phased Array tab

Note: When the Tapered Entry check box is enabled, the tapers Start Width and End Width 
boxes are initialised with the current value in the Waveguide Width box

Note: When the Symmetrical Coupler check box is disabled, the WDM Device Properties 
dialog box contains two separate pages: one for PA Section - Input Coupler and one for PA 
Section - Output Coupler.

For more information, see Phased Array Section - Input/Output Coupler in WDM_Phasar Atlas 
- Appendix I.
49



WDM_PHASAR  CREATE DEVICE
Phased Array tab

The Phased Array page of the WDM Device Properties dialog box gives you access to the 
parameters of the Phased Array Section.

To define the Phased Array parameters

Step Action 
1 In the WDM Device Properties dialog box, click the PA tab.

2 In the Waveguide Effective Index boxes, enter values for the real and the 
imaginary indices.

3 In the Number of Waveguides box, enter values for the number of the 
waveguides.

4 In the Waveguide Width box, enter a value for the width of the waveguide.

5 In the Length Increment box, enter a value for the length increment with 
respect to the previous path.

6 In the Initial Length Increment box, enter a value to define the difference 
between the distance span of the path and the length along the path.

7 Optical radiation losses can be reduced at the boundary between bent 
waveguides and straight waveguides by offsetting the straight waveguide 
from the curved one.

Note: If the Optimum Waveguide Offset checkbox is enabled, the program 
will calculate the optimum offset at every junction in the phased array, and 
make the appropriate offset in the waveguide layout.
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Figure 62 PA tab

To use the Path Template buttons

Action 
• On the PA page of the WDM Device Properties dialog box, click any of the 

Path Template buttons:

• Straight -Arc-Straight--to create a phased array whose left half consists 
of three waveguides: straight, arc, and straight.  The right one is a mirror 
image.

• Straight-Arc--to create a phased array whose left half consists of two 
waveguides: straight and arc.  The right one is a mirror image.

• Arc-Straight--to create a phased array whose left half consists of two 
waveguides: arc and straight.  The right one is a mirror image.

• ASAS 90 Degrees--create a phased array whose left half consists of four 
waveguides: arc, straight, arc, and straight.  The right one is a mirror image.

For a detailed description of the Phased Array, see Phased Array Section in WDM_Phasar 
Atlas - Appendix I.

For more information about using the path templates, see WDM_Phasar Atlas - Appendix II 
(Templates 1, 2, 3, and 4).

Tip

Instead of using the Path Template buttons on the PA page of the WDM Device Properties 
dialog box, you can use the template buttons on the Templates toolbar (see Figure 63).
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Figure 63 Templates toolbar

Clicking the Advanced … button will bring up the Phased Array Template Properties box (see 
Figure 64).

Figure 64 Phased Array Template Properties dialog box

Enabling the checkbox will force all waveguides in the phased array to have a radius no smaller 
than that specified.  If this is impossible, the waveguides which cannot conform will not be 
drawn, and the layout will show broken waveguides.  If the Auto Geometry checkbox has been 
enabled, the program will attempt to draw as many waveguides as possible by varying either 
the coupler angle or the coupler distance.

In the Iteration Step frame, the step size used in varying either the coupler angle or the distance 
between the couplers can be specified.
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Output tab
The Output tab of the WDM Device Properties dialog box give you access to the parameters of 
the Output Ports.

To define the Output device parameters

Step Action 
1 In the WDM Device Properties dialog box, click the Output tab.

2 Enable the Connect To Wafer Border check box if you want to connect the 
Output Ports to the wafer border.

3 In the Connection Offset box, type a value for the distance from edge of the 
wafer to the centre of the first port waveguide.

4 In the Port Separation box, type a value for the difference between the 
centres of the waveguides.

Note: If a non-uniform spacing is desired, switch the radio button to Individual 
and click Edit Separation, and enter the separations in the pop-up box.

5 Optical radiation losses can be reduced at the boundary between bent 
waveguides and straight waveguides by offsetting the straight waveguide 
from the curved one.

Note: If the Optimum Waveguide Offset checkbox is enabled, the program 
will calculate the optimum offset at every output waveguide junction and 
make the appropriate offset in the waveguide layout.
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Figure 65 Output tab

For more information, see Output Ports section in the WDM_Phasar Atlas - Appendix I.

Tip

To define the output device parameters, you can also use the buttons on the Output Interface 
toolbar (see Figure 66).

Figure 66 Output Interface toolbar
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Triangular Region tab
For certain applications of phasar arrays, the refractive index of the materials is modified within 
a triangular shaped region in the phasar array waveguides.  This page of the dialog box is used 
to define the dimensions of this region and the modified indices within it.  The first frame defines 
the area of the triangle.  The position of the lower vertex can be offset from the default position, 
and the direction of  the sides from this vertex defined.  Within the triangular region, the effective 
index of the wafer (in effect, the cladding for the slab waveguide model) can be set to any 
desired level.  A 'correction' can be added to the effective index of the waveguide (the slab of 
the slab model) as well.

To define the parameters of the Triangular Region

Step Action 
1 In the WDM Device Properties dialog box, click the Triangular Region tab.

2 Disable the No Index Region check box.
The default values of the offset, angles, and indices will appear in the boxes.

Figure 67 Triangular Region tab

Click OK to see the definition of the geometric parameters on the layout (see Figure 68).
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Figure 68 Geometric parameters

3 Open the dialog box again and enter desired values in the triangle definition 
frame to get the desired shape of the triangle.

4 Enter a number in the box in the second frame to re-define the effective index 
within the triangular region shown on the layout.  

5 Enter a number in the third frame as a correction to the effective index of the 
waveguides inside the triangular region.
This number will be added to the effective index of the waveguides shown in 
the PA tab of the WDM Device Properties dialog box.
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Performance menu
The Performance menu allows you to use the following commands:

Figure 69 Performance menu

Statistics Monitor

Allows you to monitor the maximum loss, the visibility, and the waveguide separation for the 
phased array, the input array, and the output array.  The Statistics Monitor command is enabled 
only when a device has been selected.

Device Statistics

Allows you to use the following commands.  These commands are available when a WDM 
device has been selected:
• Phased Array--opens the Phased Array Statistics dialog box
• Input Array--opens the Input Array Statistics dialog box
• Output Array--opens the Output Array Statistics dialog box
• Device Geometry-opens the Device Geometry dialog box

Performance Calculator

Opens the Performance Calculator dialog box which allows you to view the current parameters 
of the WDM device and to calculate its performance.  It also allows you to view the results of 
the calculation and to save them for future use.  The Performance Calculator command is 
available only if a symmetric device has been selected.
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Statistics Monitor
The Statistics Monitor command gives you access to the Statistics Monitor dialog box in which 
you can monitor some parameters related to the device performance.

The Statistics Monitor dialog box allows you to calculate and display important parameters 
related to the Phased Array, the Input Array, and the Output Array (see Figure 70).

Figure 70 Statistics Monitor dialog box
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To work with the Statistics Monitor

Step Action 
1 From the Performance menu, click Statistics Monitor.

2 In the Phased Array section, enable the following check boxes:

• Maximum Loss--to display the maximum bend loss in a waveguide 
member of the phased array

• Wg. Separation--to display the minimum waveguide separation between 
the waveguides in the phased array

• Visibility--to display how many of the waveguides are visible in the 
phased array

• Mode--to display whether the waveguides in the array are mono or multi-
mode

3 In the Input Array section, enable one or more of the check boxes.

4 In the Output Array section, enable one or more of the check boxes.

5 To recalculate the device, click one of the following buttons:

• Auto Recalculation--to recalculate the WDM device after each performed 
operation

• Recalculate Now--to recalculate the device at the present moment

Note: When you enable any or all of the check boxes, the results of the calculation of the 
device are displayed next to the enabled check boxes.

A phased array is visible if it satisfies the condition for a constant length increment between 
array paths for a given template and the geometric parameters.  The input and output 
waveguides are visible if each of them satisfies the conditions for offset and separation using 
only one curved and one straight waveguide.

You can also access the Statistics Monitor dialog box by pressing the Stats Monitor button on 
the WDM Device toolbox (see ).

Figure 71 WDM Device toolbar
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Device Statistics
The Device Statistics command allows you to calculate some parameters that are essential for 
the WDM device performance.  There are three parts of the WDM device that can be 
considered: Phased Array, Input Array, and Output Array.  The Device Geometry command 
opens the Device Geometry dialog box that provides information about Input, Output, and 
Phased Arrays.

Figure 72 Device Statistics menu

Phased Array

The Phased Array command opens the Phased Array Statistics dialog box in which you can 
view properties of each of the phased array waveguides.  The waveguides are numbered 
starting with waveguide number 1 on the left.  (The sense of direction is defined as though you 
were in the epitaxial plane observing the light coming out of the waveguides.)  For each 
waveguide, the first column indicates if the waveguide is visible.  If NO is indicated in this 
column, it means that the constraints of geometry did not permit this waveguide to be drawn.  
The second column shows the loss which WDM_Phasar calculates for this waveguide.  The 
contributions to this loss can come from bending, coupling, and material losses.  The last 
column shows the minimum distance between this waveguide and its nearest neighbour, over 
the length of this waveguide.  Please see the Phasar Atlas in Appendix 1 for the precise 
definition of the phased array waveguides.  Note that, according to the definition, the Phased 
Array Section is not included.
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Figure 73 Phased Array Statistics dialog box

You can also use three filters to define what information will be displayed.  For example, instead 
of showing the minimum separation between waveguides, you may want to see the estimated 
crosstalk level coming from this region of minimum separation.

To filter phased array statistics information

Step Action 
1 Select the WDM device.

2 From the Performance menu, click Device Statistics, Phased Array.
The WDM device statistics are being recalculated.

3 In the Phased Array Statistics dialog box, enable the Display The Crosstalk 
Level check box. The fourth column will now display the Crosstalk 
information.

4 In the Filters section, enable the Show Losses button, type a value above 
which the losses will be displayed, and click the Update button.
The values are displayed in the third column.

5 To display the coupled phased array waveguides for which the separation is 
smaller than the minimum waveguide separation, enable the Show 
Separation If < Min. Value check box and click the Update button.

6 To display only the phased array waveguides which have been redrawn after 
the calculation, enable the Show Visible Only check box and click the Update 
button.

The Phased Array Statistics dialog box displays the following warning messages:
• the number of phased array waveguides that are not visible (if any)
• the number of coupled waveguides whose separation is smaller than the minimum 
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separation of the waveguides entered in the dialog box
• the number of crossed waveguides (if any)

When the Display The Crosstalk Level (dB) check box is displayed, WDM_Phasar calculates 
the power overlap integrals based on the minimum separation and the modal field distribution.  
The integral estimates the crosstalk level.

The information in this dialog box can be saved in a file by pressing the Save button and 
entering the path and file name.

For the definition of the minimum waveguide separation, please see the Phased Array Section 
Input/Output Coupler in Appendix 1 (WDM_Phasar Parameter Atlas) of this manual.

Tip

You can also use the PA Stats button on the WDM Device toolbar (the third button from the left) 
to open the Phased Array Statistics dialog box.
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Input Array

The Input Array command opens the Input Array Statistics dialog box that contains the same 
options for the input waveguides as the options for the phased array waveguides available in 
the Phased Array Statistics dialog box.

Figure 74 Input Array Statistics dialog box

Note: The Input Array command is available only when a device has been selected.

Note: The Input Array Statistics dialog box provides no warning messages.

Tip

You can also use the IA Stats button on the WDM Device toolbar (the fourth button from the 
left) to open the Input Array Statistics dialog box.
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Output Array

The Output Array command opens the Output Array Statistics dialog box that contains the 
same options for the output waveguides as the options for the phased array waveguides 
available in the Phased Array Statistics dialog box and the options for input waveguides 
available in the Input Array Statistics dialog box.

Figure 75 Output Array Statistics dialog box

Tip

You can also use the OA Stats button on the WDM Device toolbar (the fifth button from the left) 
to open the Output Array Statistics dialog box.
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Device Geometry

The Device Geometry command opens the Device Geometry dialog box that contains three 
pages: Input Array, Phased Array, and Output Array.  Input, Phased, and Output arrays consist 
of array paths.  Each array path is built from straight and arc waveguides.  In the Device 
Geometry dialog box, you will find information about the radius and the length of each arc 
waveguide.

The picture shown in displays the length and radius of all arcs from Template 2.  Each array 
path contains two arcs: 1(1) is the first and 1(2) is the last arc from the first array path; 2(1) is 
the first and 2(2) is the last arc from the second array path, etc.  The radius and the length of 
each arc are displayed in the Radius and Length columns respectively.

Figure 76 Device Geometry dialog box

Note: The input and output array paths contain only one arc.
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Performance Calculator
The Performance Calculator opens a dialog box which contains information about the most 
important geometric, material, and modal parameters of the device.  Based on this information, 
the program can calculate the most important parameters related to the WDM device 
performance.

The Performance Calculator command is available only when a WDM device is selected and 
when the Symmetrical Couplers check box in the WDM Device Properties dialog box is 
enabled.

The Performance Calculator dialog box allows you to calculate the performance characteristics 
of the device and to view the results.

To calculate the performance characteristics of the device

Step Action 
1 From the Performance menu, click Performance Calculator.

The Performance Calculator dialog box appears.

Figure 77 Performance Calculator dialog box

Note: The Bandwidth Level is used as the reference to define the 
bandwidths.  For example, to display 3 dB bandwidths in the parameter list, 
enter -3 in this box. 

2 Click the Compute button.

3 After the Calculation is performed, the Result box appears which displays the 
initial data in the Input Information section and the results in the Results 
section.
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Figure 78 Result dialog box

4 To save the calculation results, click the Save As button.
The Save As dialog box appears (see Figure 79).

5 In the Save As dialog box, choose a folder where you want to store the 
information.

6 In the File Name box, type a name for the file.
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Figure 79 Save As dialog box

7 Click the Save button to save the results and close the Save As dialog box.

8 Click the Close button to close the Result dialog box.

Tip

Since the performance calculator works on symmetric devices only, it's better to design a new 
device as a symmetric device first, and then change it to asymmetric later.  

Note: The Performance Calculator command is available only when a WDM device is 
selected and when the Symmetrical Couplers check box in the WDM Device Properties 
dialog box is enabled.
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Simulation menu
The Simulation menu, shown in Figure 80, allows you to use the following commands:

Figure 80 Simulation menu

BPM Data

Opens the BPM Data dialog box in which you can define the simulation parameters before 
performing the simulations.  The command is available only when there is a WDM device in the 
active window. 

Edit Parameters

Opens the Edit Parameters dialog box which allows you to edit the names and the values of 
device parameters.  You can add new parameters and remove existing ones.

Scan Parameters

Opens the Scan Parameters dialog box in which you define the number of iterations, the 
scanned parameter values, and the leading parameters.

Output Data Files

Opens the Output Data Files dialog box.
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Figure 81 Output Data Files dialog box

You can enable the following check boxes:

Complex Field - to define the output data file in which the complex field will be saved at the 
end of the propagation

Power In Output Ports - to define the output data file in which the power in the output ports 
will be saved

Auto Output File Names - with this box enabled, the program will make up an output file name 
using the name of the .wdm file (in this case, "Lesson2").  Otherwise, enter the desired name 
in the adjacent box.

Calculate

Opens the BPM Data dialog box where you can not only edit the simulation parameters, but 
also run the advanced simulations.
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BPM Data
The BPM Data command opens the BPM Data dialog box. This box has three pages, the BPM 
Data page, the Input Coupler Simulation Range page, and the Output Coupler Simulation 
Range page.  A dialog box with the same name is available in BPM_2D.  However, the BPM 
Data dialog box in WDM_Phasar contains additional control parameters specialised to the 
phasar application.

BPM Data tab

This tab allows you to define the following parameters before you perform the simulation: 
Polarization, BPM Solver, Boundary Condition, Input Port, Propagation Step, Wavelength, 
Number Of Points Per Micron, and Number Of Displays.  You can also use this page to define 
whether you want to run the simulation with or without graphics, choose whether to skip the 
input coupler BPM simulation for subsequent calculations, or enter your own values for the 
modal index of the waveguides in the phased array.  The Edit PA Corrections button allows the 
optical phase and amplitude of the light at the end of the phasar array.  See the example 
"Phased Array Corrections" to see how this option works.

To define simulation parameters

Step Action 
1 In the BPM Data dialog box, click on the BPM data tab.
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Figure 82 BPM Data dialog box

2 In the Polarization section, enable one of the following buttons:

• TE

• TM

3 In the BPM Solver section, enable one of the following buttons:

• Paraxial

• Pade (1,1)

• Pade (2,2)

4 In the Boundary Condition section, enable one of the following buttons:

• Simple TBC

• Full TBC

Note: If you want to start the propagation from the Input Coupler instead of 
the Input Port, proceed to step 5. If you want to consider only the visible input 
ports of the device, proceed to step 6. (See the WDM_Phasar Atlas for the 
precise definition of the terms Input Coupler and Input Port. Basically, 
selecting the Input Coupler will ignore losses in the bends of the input 
waveguides, and does not require the input waveguides to be visible).

5 In the BPM Simulation Type section, you can choose to do the BPM 
calculation for the input coupler only once.  Choosing the Output Coupler 
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Only radio button will make the simulation start after the input coupler (at the 
beginning of the phased array) for the second and subsequent calculations.

6 In the Input Port section, enable the Start Propagation From Input Coupler 
check box.

7 In the Input Port section, indicate which input port is to be used for the 
calculation.

8 Type values in the following boxes:

• Wavelength

• Number Of Points Per Micron

• Number Of Displays

9 Enable the Run Without Graphics check box if you want to perform the 
calculation without seeing the graphics.

10 Type a value in the Propagation Step box or click the Calculate button for a 
default value.

11 In the case where accurate values of the modal index of the waveguides are 
already known (from experiment or from a simulation using BPM_CAD), 
these modal indices may be entered directly in the frame User Defined PA 
Waveguide Modal Idx.  Click the checkbox and enter the appropriate value, 
and enter a second variable if a triangular region has been defined.

When the Start Propagation From Input Coupler check box is disabled, the Input Port # box can 
have only the visible input ports (the input ports whose geometry is possible), and you can 
perform the simulation by launching a signal in one of those input ports.

When the Start Propagation From Input Coupler check box is enabled, you can start the input 
in any of the ports, if they are visible or not.
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Input and Output Coupler Simulation Range tab

This tab allows you to control the place where the independent waveguide simulation will stop 
and the light from the separate waveguides will be entered into a single simulation using BPM.  
When the waveguides approach the coupler they become closer.  Eventually the distance is so 
close that optical crosstalk takes place.  The simulation range pages estimate the level of 
crosstalk, and allow the size of the BPM region to be controlled.  The simulator should be set 
to switch to the BPM model of calculations before significant optical crosstalk takes place.  BPM 
can accurately estimate the optical crosstalk as well as the transition into the couplers and the 
propagation in the couplers.

To define the Input (or Output) Simulation Range

Step Action 
1 In the BPM Data dialog box, click on the Input (or Output) Coupler Simulation 

Range tab.

2 In the IO Star_Section frame, enter a length for the Waveguide Length of the 
Input Coupler (see Appendix 1, WDM_Phasar Atlas for a definition of this 
length).

3 Click the Calculate button next to the box labelled Crosstalk Level to get an 
estimate of the crosstalk to be found at this distance.  (Conversely, you can 
enter the desired crosstalk level first in the second box, and then click on 
Calculate of the Distance box to estimate the distance required to get this 
crosstalk level).

Figure 83 BPM Data dialog box - Input Coupler Simulation Range tab

4 Repeat the above steps for the PA Star_Section, to define at what  point the 
BPM simulation will end after the light leaves the coupler.

5 Repeat all steps above for the Output Coupler Simulation Range page.

Note: The Get Default button will set the BPM region to the maximum size.
74



WDM_PHASAR  EDIT PARAMETERS
Edit Parameters
The Edit Parameters command opens the Edit Parameters dialog box.  Sometimes it is desired 
to vary one or more of the operating parameters of the device, in order to scan this parameter 
and optimise its value, or test the device's response.  The simulator performs this function by 
identifying the relevant quantity as a 'parameter'.

The Edit Parameters dialog box, shown in Figure 84, allows you to define new parameters, to 
assign their values, to add the parameters and the values to the list, and to edit existing 
parameters.

Figure 84 Edit Parameters dialog box

When no parameter has been defined in the WDM Device Properties dialog box, there is no 
data available in the Name and the Value boxes.  If you have already defined a parameter, the 
name of the parameter and the corresponding value will be displayed when you open the Edit 
Parameters dialog box.

To define a parameter

Step Action 
1 From the Simulation menu, click Edit Parameters.

2 In the Name box, type a name for the parameter you want to edit (for 
example, "angle").

3 In the Value box, type a value for the parameter (for example, 45 degrees for 
the rotation angle).

4 Click the Add/Apply button.
The name and the value of the parameters are listed (see ).
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Figure 85 Edit Parameters dialog box - Defined parameter

5 Repeat steps 1 to 4 if you want to define another parameter.

6 Click the Close button.

To edit an existing parameter

Step Action 
1 From the Simulation menu, click Edit Parameters.

2 In the Edit Parameters dialog box, select a parameter from the list of 
parameters.

3 In the Name box, type a name if you want to change the name of the 
parameter.

4 In the Value box, type a value if you want to change the parameter value.

5 Click the Add/Apply button.

6 Click the Close button.

Tips

To delete one of the listed parameters, select it and click the Delete button.

To delete all of the listed parameters, click the Clear All button.
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Scan Parameters
The Scan Parameters command gives you access to the Scan Parameters dialog box which 
enables you to define how to scan device parameters.

Before you scan device parameters, you have to define them by using the WDM Device 
Properties dialog box or the Edit Parameters dialog box.  Once you define the scanning 
parameters, you can edit them in the Edit Parameters dialog box. Then, you can use the Scan 
Parameters dialog box to add or remove scanned parameters, to assign leading parameters, 
and to define the number of iterations.

The following procedures illustrate how the orientation angle can be scanned.

To define scan parameters

Step Action 
1 Select the device.

2 From the Edit menu, click Properties.

3 In the WDM Device Properties dialog box, click the I/O Coupler tab.

4 On the I/O Coupler page, in the Orientation Angle box, enter a name for the 
parameter you want to scan (for example, "angle").
The device is displayed, and the orientation angle of the device is now a 
parameter that can be accessed globally from the WDM - Device Layout 
Designer.
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Figure 86 WDM Device Properties - I/O Coupler tab

5 Click the OK button.
The Parameter dialog box appears.

Figure 87 Parameter dialog box

6 In the Parameter dialog box, confirm the value of the angle by clicking the OK 
button.

To edit a scan parameter

Step Action 
1 From the Simulation menu, click Edit Parameters.

2 In the Name box, enter a name to change the existing name of the parameter 
or to rename the parameter.

3 In the Value box, enter a value to change the existing parameter value or to 
define a new parameter value.
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Figure 88 Edit Parameters dialog box - defined angle

4 Click the Add/Apply button.

5 Click the Close button.

Note: If you want to edit an existing parameter, you have to select it first from the list of 
parameters in the Edit Parameters dialog box.

Note: If you want to scan this parameter, remember that the value assigned in the Edit 
Parameters dialog box has the meaning of initial value in the scanning process.

To assign the parameter range and number of iterations

Step Action 
1 From the Simulation menu, click Scan Parameters.

2 In the Scan Parameters dialog box, in the Number Of Iterations box, type a 
value (for example 10) and click the Apply button.

3 Select a parameter from the Unassigned Parameters list.

4 In the Scanned Parameters section, click the Add button.
The parameter and its initial value are listed in the second column.
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Figure 89 Scan Parameters dialog box

5 In the first column, next to row 10, type a value (for example, a value of 60 
degrees for the rotation angle).

6 Click in the box containing the word "angle" to select all rows in that column.

7 Click the Fill button to define automatically the scan values between the first 
and the last values entered.
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Figure 90 Scan Parameters dialog box - Fill

8 Click the Assign button to set the rotation angle as the leading parameter.

9 Click the OK button.

To set scanning options

Step Action 
1 In the Scan Parameters dialog box, click the OK button.

The Scanning Options dialog box appears.

2 In the Scanning Options dialog box, click any of the following buttons:

• Display--to display the scanned parameters of the device

• Silent--to perform a silent check for the geometry of the parameters of the 
device

• Don't Check--to accept the defined parameters without checking them.

Figure 91 Parameter dialog box

Tip

If the scan parameter is not a geometric one, click the Don't Check button in the Scanning 
Options dialog box.

To use the Display scanning option
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Step Action 
1 Follow steps 1 to 9 from the "To assign a leading parameter" procedure.

2 In the Scanning Options dialog box, click the Display button to open the 
Scanning Display dialog box.

3 If you get a message "WDM device geometry cannot be computed," click the 
OK button to close the WDM dialog box.

Figure 92 WDM error dialog

Such a message warns you that the first scanning value entered cannot be computed, that is, 
one or more of the waveguides cannot be displayed.

4 In the Scanning Display dialog box, use either of the following buttons:

• Forward--to move forward and display the device based on the already 
defined values

• Backward--to move backward and display the device based on the 
already defined values

• Loop--to loop over the last display of the device and the list of parameter 
values

5 To define a time interval for the scanning display, make sure the Loop button 
is enabled, enable the Timer check box, and type a value (in seconds) in the 
Time Interval check box.
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Figure 93 Scanning Display dialog box

Note: In the example shown in Figure 93, the device will be redrawn every 
three seconds, and its position will change according to the entered 
parameters.

6 Click the Play button.

Figure 94 Scanning Display dialog box - running

Note: When you use the Forward button or the Backward button in the Scanning Display 
dialog box, you can also monitor the change of the parameter values.

Tip

To interrupt the scanning display of the device, click the Discard button in the Scanning Display 
dialog box.
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Calculate
The Calculate command opens the BPM Data dialog box and gives you access to the WDM 
Device Simulator.  The menus available in the WDM Device Simulator, an application which 
contains six menus, will be discussed in a separate section.

The BPM Data dialog box allows you to use the options available in the BPM Data dialog box 
that is accessed through the BPM Data command (Simulation menu).  However, the BPM 
dialog box which opens with the Calculate command also allows you to run simulations by 
pressing the Run button.

Figure 95 BPM Data dialog box

To run simulations using the BPM Data dialog box

Step Action 
1 From the Simulation menu, click Calculate.

2 In the BPM Data dialog box, click the Run button.
The WDM Device Simulator dialog box appears and allows you to monitor the 
simulations.
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WDM Device Simulator

The Run button in the BPM Data dialog box starts the WDM Device Simulator, an application 
that provides six menus (to be discussed later). The WDM Device Simulator dialog box displays 
four quadrants, shown in Figure 96.

Figure 96 WDM Device Simulator - Input coupler

The top left quadrant displays the topographical view of the optical field. The top right quadrant 
displays a 3D view of the optical field.  The bottom left quadrant displays the cross section of 
distribution of the effective refractive index (in red) and field distribution (in blue).  The bottom 
right quadrant displays a 3D view of the effective index distribution.

When the Simulation begins, the Report dialog box appears. It displays the following data:
• the current distance of the propagation
• the number of the current propagation group
• the number of steps per group
• the reference index value
• the type of the current coupler
• the loop number in the simulation process (in scan parameter mode)
• the name and the value of the leading parameter (in scan parameter mode)

After the simulation of the input coupler is performed (see the Current Coupler item in the 
Report dialog box in Figure 96), the Phased Array Evaluation progress bar is displayed (see ).
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Figure 97 Phased Array Evalu progress bar

When the phased array simulation is completed, the WDM Device Simulator continues with the 
simulation of the Output Coupler of the device.

Figure 98 WDM Device Simulator - Output coupler

The picture above shows the quadrants, and the Report dialog box during the simulation of the 
output coupler.

If the simulations are run in scan parameter mode, at the end of the simulation, two more dialog 
boxes appear at the bottom of the WDM Device Simulator.  The one positioned on the left 
displays the field amplitude in green and the effective index in red.  The one positioned on the 
right displays the output power in dB (decibels) as a function of the leading parameter being 
scanned for all output ports (channels).
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Figure 99 WDM Device Simulator - additional dialog boxes

To see in detail the information displayed in the Field Amplitude & Effective Index dialog box 
and in the Output Power VS Scan Parameter dialog box, you can use the maximise buttons in 
each dialog box, or you can manually resize the dialog boxes (as shown in the picture below).

Figure 100 WDM Device Simulator - resized dialog boxes
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Simulation basics

The WDM Device Simulator allows you to pause and resume the simulation, to change the view 
of the graphics displayed in any of the quadrants, to rotate graphics displayed in 3D view, to 
change the size of  the graphics displayed in 3D view, and to change the axis.  For more 
information, see the "Exploring the menus in the WDM Device Simulator" section of this 
manual.

To start the WDM Device Simulator

Step Action 
1 From the Simulation menu, click BPM Data.

2 In the BPM Data dialog box, click the Run button.
The WDM Device Simulator dialog box appears.

Note: You can stop the simulations at any time by pressing the Pause button.

Tip

If you have interrupted the simulations by pressing the Pause button, you can maximise the size 
of any of the quadrants by selecting it and pressing F2.  To return to the previous view, press 
F2 again.

To pause the simulation

Action 
• In the WDM Device Stimulator dialog box, click the Pause button (the first 

button on the Calculations toolbar).

Figure 101 Calculations toolbar

To change the graphic display

Step Action 
1 On the Calculations toolbar, click the Pause button.

2 In the WDM Device Simulator dialog box, click in one of the four quadrants.

3 On the Display Tools toolbar, click any of the following buttons:

• Show Topography - to display the topography
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• Show Cube - to display a three-dimensional view

• Show Surface - to display a surface view

Tip

To change the graphic display, right-click in a quadrant and from the pop-up menu choose 
Show Surface, Show Topography, or Show Cube.

To rotate graphics displayed in a three-dimensional view

Step Action 
1 In the WDM Device Simulator dialog box, click one of the quadrants.

2 On the Display Tools toolbar, click the Show Cube button.

3 Click any of the buttons on the 3D Tool toolbar.
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Figure 102 3D Toolbar

• Turn Left (the first button on the toolbar)--to rotate the 3D view of the 
graphics to the left

• Turn Right (the second button on the toolbar)--to rotate the 3D view of the 
graphics to the right

• Tilt Down (the third button on the toolbar)--to tilt the graphics down

• Tilt Up (the fourth button on the toolbar)--to tilt the graphics up

• Zoom In (the fifth button on the toolbar)--to increase the size of the 
graphics

• Zoom Out (the last button on the toolbar)--to decrease the size of the 
graphics

Note: You can also use Show Surface mode to rotate graphics, but you'll need more time 
to redraw it.

To change the size of graphics displayed in 3D view

Step Action 
1 Follow steps 1 and 2 from “To rotate graphics displayed in a three-

dimensional view” on page 89.

2 Click any of the buttons on the Ratio Tools toolbar.

Figure 103 Ratio Tools toolbar

• Increase Height (the first button on the toolbar)--to increase the height of 
the graphics displayed in 3D

• Decrease Height (the second button on the toolbar)--to decrease the 
height of the graphics displayed in 3D

• Increase Depth (the third button on the toolbar)--to increase the depth of 
the graphics displayed in 3D

• Decrease Depth (the last button on the toolbar)--to decrease the depth of 
the graphics displayed in 3D

To change the axes

Step Action 
1 In the WDM Device Simulator dialog box, click one of the quadrants.

2 On the Axes Tools toolbar, click any of the following buttons.
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Figure 104 Axes Tools toolbar

X-axis Settings - to open the X Axis dialog box which allows you to define the values, the ticks, 
the labels, and the captions of the x-axis

Figure 105 X-axis dialog box

Y-axis Settings - to open the Y Axis dialog box which allows you to define the values, the ticks, 
the labels, and the captions of the y-axis
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Figure 106 Y axis dialog box

Z-axis Settings - to open the Y Axis dialog box which allows you to define the values, the ticks, 
the labels, and the captions of the y-axis
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Figure 107 Z axis dialog box

Tip

To change the axes, you can also right-click in a quadrant and from the pop-up menu choose 
Axes, X-Axis, Y-Axis, or Z-Axis.

To define options for the Field Amplitude & Effective Index dialog box

Step Action 
1 In the WDM Device Simulator dialog box, right-click the Effective Amplitude 

& Effective Index dialog box.
A pop-up menu appears, as shown in Figure 108.
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Figure 108 Field Amplitude/Effective Index dialog box

2 From the pop-up menu, choose any of the following commands:

• Print - to print the data available in the dialog box

• Axes - to choose any of the options available in the submenu:

Figure 109 Axes menu

• Title - to open the Title dialog box in which you can change the caption, 
the X and Y positions, and the scale factor.

Figure 110 Title dialog box

Note: The Symbols button opens the Symbols Map dialog box.  This box has 
a list of symbols available, and shows the key sequence which will generate 
them.

• Curve Properties--to open the Curve Properties dialog box.  This box 
defines the colour and line style properties for the display of the field 
amplitude and the effective index.
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Figure 111  Curve Properties dialog box

Note: When the Visible check box is enabled, the selected item (field 
amplitude or effective index) is visible on the screen.  When disabled, the 
curve is not displayed.

To define options for the Output Power vs Scan Parameter dialog box

Step Action 
1 In the WDM Device Simulator, right-click the Output Power vs Scan 

Parameter dialog box.
A pop-up menu appears, as shown below in Figure 112.

2 From the pop-up menu, choose any of the following commands:

• Print - to print the data available in the dialog box.

• Axes - to choose any of the options available in the submenu: Bottom X-
Axis or Left Y-Axis.
— The Bottom X-Axis command opens the Bottom X-Axis dialog box which 

allows you to define the values, the ticks, the labels, and the captions of 
the bottom x axis (as shown below).  When the Show In dB check box is 
enabled, the data is displayed in decibels. See Figure 113.

— The Left Y-Axis command opens the Left Y Axis dialog box which allows 
you to define the values, the ticks, the labels, and the captions of the left 
y axis (as shown below).  When the Show In dB check box is enabled, 
the data is displayed in decibels.  If the Auto Scale check box is enabled, 
the axis range will be automatically adjusted when the scale is switched 
from linear to dB. See Figure 114.
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Figure 112 Output Power vs Scan Parameter dialog box

Figure 113 Bottom X axis dialog box
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Figure 114 Left Y axis dialog box

• Title - to open the Title dialog box in which you can change the caption, 
the X and Y positions, and the scale factor. See Figure 115.

Figure 115 Title dialog box
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The Symbols button opens the Symbols Map dialog box.  This box has a list 
of symbols available, and shows the key sequence which will generate them.

• Curve Properties--opens the Curve Properties dialog box, in which you 
can define the color, line, and visible display properties for each Output 
Power channel. See Figure 115.

Figure 116 Curve Properties dialog box

• Statistics--opens the Statistics dialog box which gives you information 
about channel amplitude, bandwidth, CrossTalk level, and channel spacing.  
The bandwidth can be recalculated for any bandwidth level after entering the 
value of that level.

Figure 117 Statistics dialog box

Note: The Save and Save As buttons also allow you to save the statistics report.
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Exploring the menus in the WDM Device Simulator
The WDM Device Simulator opens when the simulations are running or when they are 
completed. The Simulator has two modes of appearance: graphical and non-graphical.

You can use the following menus:

File menu

The File menu allows you to use the commands shown in the picture below.

Figure 118 WDM Device Simulator File menu

Print

Allows you to print the current file.

Print Setup

Allows you to set printing options.

Print Preferences

Allows you to define printing preferences.

Exit

Allows you to exit the WDM Device Simulator.
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Edit menu

Figure 119 WDM Edit menu

Copy

Allows you to copy the device to the Clipboard.

Properties

Opens the Topography Properties dialog box (shown below) and allows you to define the 
display of the contour lines, the colour gradation, and the axes. You can also perform fast 
drawing and apply inverted colour mapping, in which the colours identified as the maximum and 
minimum are interchanged.  The Properties command is available only when the simulation has 
been completed.

Figure 120 Topography Properties dialog box

The Palette button in this dialog box opens the Palette Selection dialog box.  In the Palette 
Selection section, you can choose any of the predefined colours available in the Palette Choice 
list box.

When you choose Custom from the Palette Choice list box, you can set your own values in the 
Custom Palette Settings section and preview the results by pressing the Preview button.
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Figure 121 Palette Selection dialog box

Display Data As

Provides three options for data display:
• Amplitude
• Intensity
• dB

Note: The Display Data As command is not available during a simulation.

Restore Defaults

Allows you to use the defaults of the WDM Device Simulator.
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View menu

The View menu allows you to use the command listed in the picture below:

Figure 122 WDM View menu

All Quadrants

Allows you to view all four quadrants or a single quadrant on your screen.  Selecting this 
command or pressing F2 displays all quadrants (as shown below):
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Figure 123 Quadrants view

Clicking F2 again displays a single quadrant (as shown below).
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Figure 124 Optical Field dialog box

View Point

Opens the View Point dialog box, which contains all changes of the point of observation used 
in the three dimensional graphic display.

Figure 125 View Point dialog box

In this dialog box, you can define the Camera Settings and the Ratio settings.  By using the 
Draw button, you can draw the device.  By using the Default button, you can restore the default 
parameters for the View point dialog box.

Hide Graphics

This option is available while a simulation is running.  Selecting it will perform the simulation in 
a non-graphic mode.  The Hide graphics command opens the WDM Device Simulator dialog 
box, shown below, in which you can view the progress of the simulation.
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Figure 126 WDM Device Simulator dialog box

This dialog box allows you to suspend the simulation by clicking the Pause button, to restart the 
simulation by clicking the Resume button, and to switch to the normal, graphic mode display by 
using the Graph button.

Monitor

Disabled for the current version of WDM_Phasar.

Report Dialog

Allows you to hide or display the Report dialog box (see Figure 127).

Figure 127 Report dialog box

View Toolbars

Toggles the display of the toolbars (see ).
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Figure 128 View Toolbars menu

When a toolbar is displayed, a check mark appears next to the menu item.

From the View menu, click Toolbars and click any of the following:

Main Toolbar - to hide or display the Main toolbar.

Figure 129 Main toolbar

3D Tools - to hide or display the 3D Tools toolbar.

Figure 130 3D Tools toolbar

Axes Tools - to hide or display the Axes toolbar.

Figure 131 Axes Tools toolbar

Display Tools - to hide or display the Display Tools toolbar.

Figure 132 Display Tools toolbar

Calculations - to hide or display the Calculations toolbar.
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Figure 133 Calculations toolbar

Ratio Tools - to hide or display the Ratio Tools toolbar.

Figure 134 Ratio Tools toolbar
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Calculations menu

Allows you to control the simulation process and the calculation of the device.

Figure 135 Calculations menu

Pause

Pauses the simulation.

Resume

Resumes the simulation.

Stop

Discontinues the simulation.
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Settings menu

Allows you to use the commands listed in the menu below:

Figure 136 Settings menu

Buffered Drawing

When disabled, redraws all quadrants at every run; when enabled, adds only the last step to 
the graph.

Colours

Opens the Colors Selection dialog box.

Figure 137  Colors Selection dialog box

The Color Selection dialog box allows you to define and change the colours of the background, 
the text, the axis, the graph lines, and the lower surface.  When you click any of the buttons in 
the Colors Selection dialog box, the following colours are displayed in the Color dialog box:
109



WDM_PHASAR  CALCULATE
Figure 138 Color dialog box

The Define Custom Colors dialog box expands the Colors dialog box and allows you to 
customise the colours to suit your preferences.  Once you have defined your own colour, you 
can add it to the Custom Colors section and store it there for future use.

Figure 139 Color dialog box - custom

Palette

Opens the Palette Selection dialog box.

The Palette Selection dialog box allows you to choose from the colour options available in the 
Palette Choice list box.  When you select Custom from the Palette Choice list, you can enter 
values in the Custom Palette Settings section.  When you click the Color buttons in the Starting 
Values and the Ending Values sections, the Color dialog box opens (see the Colours 
command), and you can define the colours you want to use.
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Figure 140 Palette Selection dialog box

Before applying the new colours to the components of your device, you can preview the result 
in the Preview section by clicking the Preview button.

Axis

Allows you to use any of the following commands:

X Axis - opens the X Axis dialog box.

In this dialog box, you can define the values, the ticks, the labels, and the captions of the X-
axis.  In the Captions section, the Symbols button allows you to choose the symbols you want 
to use by opening the Symbols Map dialog box.

For more information, see the "To change the axis" procedure in the Simulation Basics section 
of this manual.

Y Axis - opens  the Y Axis dialog box.  The options in this dialog box are the same as the ones 
in the X Axis dialog box.

For more information, see the "To change the axis" procedure in the Simulation Basics section 
of this manual.

Z Axis - opens the Z Axis dialog box.  The options this dialog box provides are the same as the 
ones in the X Axis and Y Axis dialog boxes.

For more information, see the "To change the axis" procedure in the Simulation Basics section 
of this manual.

Title

Allows you to change the names of any of the quadrants. To do this, click in a quadrant and 
from the Settings menu click Title to open the Title dialog box.
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Figure 141 Title dialog box

The Title dialog box also gives you access to the Symbols Map dialog box through the Symbols 
button.
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Help menu

Allows you to use the standard Help commands:

Figure 142 Help menu

You can also use the Help menu to get information about the WDM Device Simulator.

Preferences menu

The Preferences menu allows you to define the layout settings and waveguide colors.  It 
enables you to use the Snap To Grid and the Auto Scroll commands.  Using the Preferences 
menu, you can also save the current settings at any time during your work or when you exit the 
program.  You can use the following commands:

Figure 143 Preferences menu

Layout Options

Opens the Layout Settings dialog box.  In this dialog box, you can define the grid settings, the 
settings for the layout axes, and the display ratio.  For more information about layout settings, 
see the "Layout Section" in this manual.

Waveguide Colours

Opens the Waveguide Colors dialog box which allows you to define the frame colours, the path 
colours, and the fill colours.  You can also enable the Fill Waveguide check box to apply fill 
colour to the waveguide.
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Figure 144 Waveguide Colors dialog box

When you press any of the colour buttons, the Color dialog box opens in which you can choose 
colours from the Basic Colors section or define custom colours.  For more information about 
applying colours using the Colors dialog box, see the "Layout Options" section in this manual.
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Define Color Scheme

Click the Define Color Scheme button to display the Define Color Scheme dialog box.
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Figure 145 Color Scheme dialog box

Set Reference value

Specifies the range of the colour scheme. "Min" specifies minimum value for the colour scheme. 
"Max" specifies maximum value for the colour scheme.

Palette Select

Specifies what type of palette to be used as the colour scheme. There are eight types of 
palettes to select: Dark Blue, Light Blue, Dark Green, Light Green, Dark Red, Light Red, 
Rainbow, and Custom. The custom palette range is taken from the two colours in the dialog 
box.

Number of Colors

Specifies number of colours for colour scheme. Range is between 4 and 256.

Preview button

Set Color wash control to display selected palette. 

Reference Value

Specifies which value is used for colour scheme: Real, Imaginary and Amplitude.  

Scale

Specifies scale for colour scheme. There are three types: Linear, Exponential, and Logarithmic.

Set Min button

Pop up color dialog box to select minimum color for custom palette.
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Color bar for min

Displays minimum colour for custom palette.

Set Max button

Pop up colour dialog box to select maximum colour for custom palette.

Color bar for max

Displays maximum colour for custom palette.

Color Wash control

Displays current palette for colour scheme.

Snap To Grid

Allows you to snap to a certain point in the grid.  You can also use the Snap To Grid button on 
the Draw toolbar (shown below).

Figure 146 Draw toolbar - Snap to Grid

Auto-Scroll

Enables the auto-scroll option.

Save Settings Now

Saves the current settings when you use the command.

Save Settings On Exit

Save the settings when you exit the application.
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Layout Options
The Layout Options command opens the Layout Settings dialog box.

Layout Settings dialog box

The Layout Settings dialog box allows you to define the grid settings, the settings for the Layout 
axes, and the display ratio.

Figure 147 Layout Settings dialog box

To define the grid settings

Step Action 
1 From the Preferences menu, click Layout Settings.

2 In the Grid section, choose a grid type from the Type list box.

3 Choose a line style from the Line Style list box.

Note: The options in the Line Style list box are available if you have chosen 
the following grid types from the Type list box: X Lines, Z Lines, or XZ Lines.

4 Click the Color button to choose a grid colour.
The Color dialog box appears.
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Figure 148 Color dialog box

5 If you want to use a colour from the Basic Colors palette, proceed to step 6.  
If you want to define a custom colour, proceed to step 7.

6 Choose a colour from the Basic Color palette.

7 Click the Define Custom Color button to expand the Color dialog box.

Figure 149 Color dialog box - custom

8 To define a custom colour, click the Add to Custom Colors button.

9 Enable the Print check box if you want to print the grid.

10 In the Z-spacing and X-spacing boxes, type values.
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Figure 150 Grid panel

To define the layout axes settings

Step Action 
1 From the Preferences menu, click Layout Settings.

2 In the Layout Axes section, type a value in the Line Width box.

3 From the Line Style list box, choose a line style.

4 Follow steps 4 to 7 from the previous procedure.

5 Enable the Print check box if you want to print the Layout axes.

6 Enable the Show check box if you want to view the axes during your work.

Figure 151 Layout axes panel
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To define the background colour settings

Step Action 
1 From the Preferences menu, click Layout Settings.

2 In the Background section, click the Color button to change the background 
colour settings.

3 Follow steps 4 to 6 in “To define the grid settings”.

Figure 152 Background panel

To define the display ratio settings

Step Action 
1 From the Preferences menu, click Layout Settings.

2 In the Display Ratio section, type values in the Z or Y box (if they are 
enabled).

Figure 153 Display ratio panel
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Window menu
The Window menu allows you to use the following commands: New Window, Cascade, Tile, 
and Arrange Icons.  It also lists the currently open files and shows a check mark next to the file 
which is in view (see Figure 154).

Figure 154 Window menu

New Window

Opens a new window.

Cascade

Partially displays all open files as a stack of offset windows, with the active window on top, and 
the title bars visible for all files (see Figure 155).

Figure 155 Cascaded display

Tile

Splits the wafer horizontally to display all open files (see Figure 156).
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Figure 156 Tiled display

Arrange Icons

Allows you to arrange the icons.
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Help menu
The Help menu provides the options shown in .

Figure 157 Help menu

Help Topics

Displays help topics organised categorically into books.  Double-clicking a particular category 
allows you to see and use the topics available in the category.  Double-clicking a topic opens a 
help window.  To close a book, double-click it.

Using Help

Provides information about using online Help.

About WDM_Phasar

Provides information about WDM_Phasar.
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